MSBuild with Silverlight / RIA Services

MSBuild with Silverlight / RIA Services

by jbrooks 2. November 2011 09:36

I introduced a Silverlight project to my ASP.Net application and every thing worked fine in development but when I went to build it with out automatic build process MSBuild would kick out the following error:

[msbuild]   App.xaml.cs(2,17): error CS0234: The type or namespace name 'Services' does not exist in the namespace 'MyProject.Web' (are you missing an assembly reference?)

Had to change a registration key, the DefaultToolsVersion was set to 2.0, changed  it to 4.0

image

 

Ran the install selecting repair for the Silverlight 5.0 sdk (silverlight5_sdk.exe) – it was originally installed as part of the tool kit, but found others saying the real install still needed to be done to get it to work with MSBuild.

Next go the error:  error MSB4044: The "CreateRiaClientFilesTask" task was not given a value for the required parameter "ClientFrameworkPath"

Had to install EntityFramWork4.1 on my build server and then reboot.

Now on to the next problem.

Tags:

Silverlight | Development

Comments (3) -

joe
joe United States
1/19/2012 6:44:52 AM #

did you manage to get your RIA + SL project to build fully after taking these steps?

joe
joe United States
1/19/2012 7:44:12 AM #

nvm the 2.0 -> 4.0 change is all that seems to be needed.

jbrooks
jbrooks United States
1/19/2012 11:11:29 AM #

Yes, it worked after I did these steps.

Add comment

  Country flag

biuquote
  • Comment
  • Preview
Loading